Сообщения без ответов | Активные темы Текущее время: Сб июл 21, 2018 12:55 pm



Ответить на тему  [ Сообщений: 54 ]  На страницу Пред.  1, 2, 3, 4  След.
Вопрос по Штрих-М : Синхронизатор 
Автор Сообщение
Новичок

Зарегистрирован: Пт окт 27, 2006 1:16 pm
Сообщения: 13
Сообщение 
Спасибо, я чего-то сам до этого не догадался ))))


Вт окт 16, 2007 4:16 pm
Профиль ICQ
Участник
Аватара пользователя

Зарегистрирован: Вт апр 24, 2007 5:18 pm
Сообщения: 1577
Откуда: Штрих-М
Сообщение 
Были рады Вам помочь.

_________________
С уважением, Иванов Алексей Сергеевич,
Инженер технической поддержки
НТЦ "ШТРИХ-М",
support@shtrih-m.ru
тел. (495) 787-6096.


Вт окт 16, 2007 4:18 pm
Профиль
Новичок

Зарегистрирован: Сб окт 07, 2006 4:05 pm
Сообщения: 13
Откуда: Москва
Сообщение 
Процедура ПриЗавершенииРаботыСистемы()
ВнешняяКомпонента.Beeper(1);
Если ПустоеЗначение(ТекущийПользователь)=0 Тогда
СохранитьЗначение("ПоследнийПользователь",ТекущийПользователь);
КонецЕсли;
//Если (Константа.СпособОбменаДанными=2) И (Константа.ВремяВозобновленияСвязи>=0) Тогда
// Попытка
// ФС.УдалитьФайл(СокрЛП(Константа.КаталогСинхронизатора)+?(Прав(СокрЛП(Константа.КаталогСинхронизатора),1)="\","","\")+"ECR\"+Константа.НомерПОС+".!");
// Исключение
// КонецПопытки;
//КонецЕсли;
КонецПроцедуры

_________________
Андрей К.
Универсам Александр СМ


Ср окт 17, 2007 4:29 pm
Профиль
Участник
Аватара пользователя

Зарегистрирован: Вт ноя 08, 2005 3:49 pm
Сообщения: 5335
Откуда: Shtrih-M
Сообщение 
k0l0b0k писал(а):
Процедура ПриЗавершенииРаботыСистемы()
ВнешняяКомпонента.Beeper(1);
Если ПустоеЗначение(ТекущийПользователь)=0 Тогда
СохранитьЗначение("ПоследнийПользователь",ТекущийПользователь);
КонецЕсли;
//Если (Константа.СпособОбменаДанными=2) И (Константа.ВремяВозобновленияСвязи>=0) Тогда
// Попытка
// ФС.УдалитьФайл(СокрЛП(Константа.КаталогСинхронизатора)+?(Прав(СокрЛП(Константа.КаталогСинхронизатора),1)="","","")+"ECR"+Константа.НомерПОС+".!");
// Исключение
// КонецПопытки;
//КонецЕсли;
КонецПроцедуры


О чем идет речь?

_________________
С уважением, Егоров Вячеслав,
инженер технической поддержки ЗАО "Штрих-М",
e-mail: support@shtrih-m.ru,
тел. (495) 787-60-96.


Ср окт 17, 2007 5:14 pm
Профиль WWW
Новичок

Зарегистрирован: Пн фев 26, 2007 12:57 pm
Сообщения: 16
Сообщение 
Ivanov_Alexey писал(а):
Выставьте константу "НеЗагружатьПриЗапуске" в снхронизаторе.


Синхронизатор 1.3.0.1

В конфигурации не нашел такой константы...
Она в обновлении неофициальном?


Чт дек 27, 2007 3:11 pm
Профиль
Участник
Аватара пользователя

Зарегистрирован: Вт апр 24, 2007 5:18 pm
Сообщения: 1577
Откуда: Штрих-М
Сообщение 
Обновите синхронизатор не объединением конфигураций, а с помощью "Загрузиь измененную конфигурацию". Заходим в конфигуратор, в главном меню конфигурация, "Загрузиь измененную конфигурацию", константа "НеЗагружатьПриЗапуске". После обновления костанта появится.

_________________
С уважением, Иванов Алексей Сергеевич,
Инженер технической поддержки
НТЦ "ШТРИХ-М",
support@shtrih-m.ru
тел. (495) 787-6096.


Чт дек 27, 2007 6:37 pm
Профиль
Новичок

Зарегистрирован: Пн фев 26, 2007 12:57 pm
Сообщения: 16
Сообщение 
Ivanov_Alexey писал(а):
Обновите синхронизатор...


Из чего обновлять? Где взять обновление?
Просьба выслать на d.r.o.n<собака>mail.ru


Пн дек 31, 2007 11:23 am
Профиль
Участник
Аватара пользователя

Зарегистрирован: Вт апр 24, 2007 5:18 pm
Сообщения: 1577
Откуда: Штрих-М
Сообщение 
Выслал версию синхронизатора 1.4 на e-mail из профиля. Версия официально еще не вышла.

_________________
С уважением, Иванов Алексей Сергеевич,
Инженер технической поддержки
НТЦ "ШТРИХ-М",
support@shtrih-m.ru
тел. (495) 787-6096.


Ср янв 09, 2008 10:17 am
Профиль
Новичок

Зарегистрирован: Пт фев 01, 2008 10:28 pm
Сообщения: 6
Сообщение 
Здравствуйте, подскажите с настройками в Синхронизаторе! В частности не понятно про "Запрос реквизитов", для чего и что там прописать. И "Выгрузка транзакци", для чего и подробнее о том что должно быть прописано. Спаибо!


Вт фев 19, 2008 3:04 pm
Профиль
Участник
Аватара пользователя

Зарегистрирован: Вт апр 24, 2007 5:18 pm
Сообщения: 1577
Откуда: Штрих-М
Сообщение 
Из документации о "Штрих-М: Синхронизатор":
"Программа позволяет выгружать параметры товаров, указанных в запросе. Для этого нужно
настроить следующие поля:
• Имя файла запроса реквизитов
В этом поле необходимо указать файл запроса реквизитов. Программа каждый момент
времени будет искать указанный файл. Если файл существует, то происходит выгрузка параметров
товаров, указанных в запросе в файл, указанный в поле «Имя файла выгрузки реквизитов». После
выгрузки параметров служебный файл удаляется.
• Имя файла выгрузки реквизитов
В этом поле необходимо указать файл выгрузки реквизитов".

"Выгрузка транзакций
Функция выгрузки транзакций с касс может применяться для возможности обработки
системой товароучета кассовых транзакций в реальном времени. При использовании данной
функции транзакции, полученные с касс, выгружаются в общий файл. Система товароучета после
обработки должна удалить этот файл.
• Выгружать файлы с транзакциями с кассс
Для возможности выгрузки транзакций необходимо установить данный флаг. Если
обработка транзакций в реальном времени не поддерживается системой товароучета, флаг
устанавливать не следует.
• Имя файла транзакций с касс
В этом поле необходимо указать файл, в который будут выгружаться транзакции с касс."

_________________
С уважением, Иванов Алексей Сергеевич,
Инженер технической поддержки
НТЦ "ШТРИХ-М",
support@shtrih-m.ru
тел. (495) 787-6096.


Вт фев 19, 2008 5:14 pm
Профиль
Новичок

Зарегистрирован: Вт июн 03, 2008 1:38 pm
Сообщения: 27
Откуда: Кострома
Сообщение 
Нельзя ли тоже получить Синхронизатор 1.4? В 1.3 катастрофически не хватает настроек...


Сб июл 05, 2008 2:07 pm
Профиль ICQ
Участник
Аватара пользователя

Зарегистрирован: Вт ноя 08, 2005 3:49 pm
Сообщения: 5335
Откуда: Shtrih-M
Сообщение 
Выслал на e-mail из профиля.

_________________
С уважением, Егоров Вячеслав,
инженер технической поддержки ЗАО "Штрих-М",
e-mail: support@shtrih-m.ru,
тел. (495) 787-60-96.


Пн июл 07, 2008 8:58 am
Профиль WWW
Новичок

Зарегистрирован: Ср июн 13, 2007 7:11 am
Сообщения: 35
Сообщение 
Можно мне тоже синхронизатор 1.4 ?
почта osmanova(sobaka)bk.ru ? очень буду ждать, у нас та же проблема


Пт окт 24, 2008 7:54 am
Профиль
Участник

Зарегистрирован: Ср апр 11, 2007 3:03 pm
Сообщения: 4691
Сообщение 
Выслал.

_________________
С уважением, Прохоров Александр Сергеевич,
Инженер технической поддержки
НТЦ "ШТРИХ-М",
support@shtrih-m.ru
тел. (495) 787-6096.


Пт окт 24, 2008 1:51 pm
Профиль
Новичок

Зарегистрирован: Ср июн 13, 2007 7:11 am
Сообщения: 35
Сообщение 
Хочу еще раз поднять эту тему-у нас нет Штрих-М Кассира у нас
РМК на МиниПосе, поэтому закамментить обработку соответствующую мы не можем(или не знаем как)

обновили Синхронизатор до 1.4 (загрузить измененную конфигурацию), скопировали Dll-ку соответствующую. констата нужная там имеется -но там нет никакой кнопки в настройке, чтобы изменить ее значение. Ладно, сами приделали кнопку и изменили константу на 1.
Все равно при включении, или разрыве связи кассы начинают грузится - а хочется только принудитель по кнопке "Обновить"
Что делать в нашем случае?


Пт ноя 07, 2008 8:43 am
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 54 ]  На страницу Пред.  1, 2, 3, 4  След.

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.
Русская поддержка phpBB