Сообщения без ответов | Активные темы Текущее время: Ср дек 11, 2019 5:43 pm



Эта тема закрыта, вы не можете редактировать и оставлять сообщения в ней.  [ Сообщений: 46 ]  На страницу Пред.  1, 2, 3, 4
Как из DrvFR1C получить DrvFR? 
Автор Сообщение
Новичок

Зарегистрирован: Пн авг 15, 2011 10:24 am
Сообщения: 33
Сообщение Re: Как из DrvFR1C получить DrvFR?
Добрый день,

fixin, огромное спасибо за функцию, реально работает!
но вы в своей функции использовали ПереводИзСистемыСчисленияВЧисло и ПереводЧислаВСистемуСчисления а их кода нет.

Я выложу свой вариант эти функций, думаю понятно какая что делает.

Функция Из_10_В_Любую(Знач Значение=0,Нотация=36) Экспорт
Если Нотация<=0 Тогда Возврат("") КонецЕсли;
Значение=Число(Значение);
Если Значение<=0 Тогда Возврат("0") КонецЕсли;
Значение=Цел(Значение);
Результат="";
Пока Значение>0 Цикл
Результат=Сред("0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ",Значение%Нотация+1,1)+Результат;
Значение=Цел(Значение/Нотация) ;
КонецЦикла;
Возврат Формат(Результат, "ЧГ=0");
КонецФункции

Функция Из_Любой_В_10(Знач Значение="0",Нотация=36) Экспорт
Если Нотация<=0 Тогда Возврат(0) КонецЕсли;
Значение=СокрЛП(Значение);
Если Значение="0" Тогда Возврат(0) КонецЕсли;
Результат=0;
Длина=СтрДлина(Значение);
Для Х=1 По Длина Цикл
М=1;
Для У=1 По Длина-Х Цикл М=М*Нотация КонецЦикла;
Результат=Результат+(Найти("0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ",Сред(Значение,Х,1))-1)*М;
КонецЦикла;

Возврат Формат(Окр(Результат), "ЧГ=0");
КонецФункции


Ср июн 01, 2016 12:55 pm
Профиль
Показать сообщения за:  Поле сортировки  
Эта тема закрыта, вы не можете редактировать и оставлять сообщения в ней.   [ Сообщений: 46 ]  На страницу Пред.  1, 2, 3, 4

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 27


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.
Русская поддержка phpBB